如何在Dart中将代码迁移到空安全

最近 Flutter 团队宣布 Dart 语言现在支持声音空安全!并且在 Dart 2.12 和 Flutter 2 中可用。我想将应用程序代码迁移到空安全。

如何将我的包迁移到空安全,

如果有人可以提供有关迁移到 null-safety 的说明,那就太好了。

回答

这里有一个相当好的指南:https : //dart.dev/null-safety/migration-guide

但是基本上你应该等到你的包的所有依赖都先迁移到空安全,然后你就可以开始迁移了。

您可以dart pub outdated --mode=null-safety
使用 dart migrator检查迁移了哪些 deps之后dart migrate 。这是一个交互式工具,可帮助您迁移代码。


以上是如何在Dart中将代码迁移到空安全的全部内容。
THE END
分享
二维码
< <上一篇
下一篇>>