炫意html5
最早CSS3和HTML5移动技术网站之一

Linux系统下如何安装python解释器

我这里使用的时centos7-mini,centos系统本身默认安装有python2.x,版本x根据不同版本系统有所不同,可通过 python –V 或 python –version 查看系统自带的python版本

有一些系统命令时需要用到python2,不能卸载

安装依赖包   

1.首先安装gcc编译器,gcc有些系统版本已经默认安装,通过  gcc –version  查看,没安装的先安装gcc,yum -y install gcc

2.安装其它依赖包,(注:不要缺少,否则有可能安装python出错,python3.7.0以下的版本可不装 libffi-devel )

yum -y install zlib-devel bzip2-devel openssl-devel ncurses-devel sqlite-devel readline-devel tk-devel gdbm-devel db4-devel libpcap-devel xz-devel libffi-devel

下载python源码(按需下载)

在https://www.python.org/ftp/python/中选择自己需要的python源码包,我下载的是python3.7.0

(大家也可以去https://www.python.org官网首页下载,找到downloads,就可以选择想要的版本下载了)

下载

wget https://www.python.org/ftp/python/3.7.0/Python-3.7.0.tgz

解压Python-3.7.0.tgz

tar -zxvf Python-3.7.0.tgz

建立一个空文件夹,用于存放python3程序

mkdir /usr/local/python3

执行配置文件,编译,编译安装

cd Python-3.7.0
./configure --prefix=/usr/local/python3
make && make install

安装完成没有提示错误便安装成功了

建立软连接 

ln -s /usr/local/python3/bin/python3.7 /usr/bin/python3
ln -s /usr/local/python3/bin/pip3.7 /usr/bin/pip3

测试一下python3是否可以用

[root@mini Python-3.7.0]# python3
Python 3.7.0 (default, Jul 28 2018, 22:47:29) 
[GCC 4.8.5 20150623 (Red Hat 4.8.5-28)] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> print("hello world!")
hello world!
>>> exit()
[root@mini Python-3.7.0]# pip3 --version
pip 10.0.1 from /usr/local/python3/lib/python3.7/site-packages/pip (python 3.7)

python3.7.0可以正常使用,至此,linux系统下的Python安装就完成了。

炫意HTML5 » Linux系统下如何安装python解释器

CSS3教程HTML5教程